Menampilkan informasi jumlah user yang sedang aktif di MIKROTIK

Rabu, 25 Januari 2012

Ada kala ada beberapa user yang bertanya kepada kita mengenai berapa sih user yang online ? biasanya ini terjadi ketika layanan internet kita menggunakan jaringan hotspot dimana menerapkan sistem voucher. Mungkin ini bagi sebagian admin merupakan informasi yang sensitif. tapi untuk ada juga yang mau berbaik hati memberikan informasi tersebut. cara ini dibuat menggunakan script yang dan sechedul yang tiap berapa detik akan memberikan informasi tersebut kepada client.
berikut caranya yang bisa diterapkan : 1. buka program kesayangan dulu, WINBOX
2. masukan script berikut di :
#-----------------------------------------------dari sini
#BUAT DULU FILE (namanya info.txt)
/file print file=hotspot/info

#SCRIPT JUMLAH USER------------
/system script
add name=jumlahuser policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source={
/ip hotspot active
:global yoi;
:global tri;
# cek jumlah user yang aktif menggunakan radius
:set yoi ([print from=[/ip hotspot active find radius=yes] count-only])
# cek jumlah user yang aktif menggunakan trial (jika fasilitas trial aktif)
:set tri ([print from=[/ip hotspot active find login-by=trial] count-only])
#menginput file ke "info.txt" yang sebelumnya sudah dibuat
/file set hotspot/info.txt contents= \
"SEKEDAR INFORMASI : \r\nyang online (voucher) ada  : $yoi orang\r\nyang online (trial)   ada  : $tri orang\r\n\r\nklik kanan'reload' atau tekan F5 untuk update info"
}

#SCRIPT BUAT SCHEDULE NYA
/system scheduler
add comment="BUAT FILE" disabled=no interval=5s name=buatfile on-event=jumlahuser policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    Jan/02/1970 start-time=05:00:00
#-----------------------------------------------sampai disni
3. oke selesai
Trus bagaimana melihatnya ???
nah caranya mudah, buka di browsernya (kebetulan saya disini menggunakan MOZILLA FIREFOX)
ketik nama domainnya contoh "http://be-asahotspot.net/info.txt" atau ip domain WLAN anda contoh "http://192.168.78.3/info.txt"
taraaaaa !!!
ntar tampilannya seperti ini:
SEKEDAR INFORMASI : 
yang online (voucher) ada  : 1 orang
yang online (trial)   ada  : 0 orang
klik kanan'reload' atau tekan F5 untuk update info
 
update:
sedikit trik tambahan, jika ingin tampilan itu muncul di halaman login, bisa diakali dengan menggunakan tag iframe di halaman login, selamat berkreasi

Comments

4 Comments

RSS
  1. Komentar ini telah dihapus oleh pengarang.

    BalasHapus
  2. Punya saya kok gk bsa ya gan

    BalasHapus
  3. /file print file=hotspot/info diganti menjadi
    /file print file=hotspot/info.txt

    BalasHapus

BELAJAR MIKROTIK

Kadang sama-sama tidak tahu, mau mencoba, dan berusaha untuk berbagi (sorry..under construction...!!!)